Search found 1318 matches

by Gordon
15 Jun 2017, 15:18
Forum: B2 & B3 Support
Topic: B3 internal wifi interface slot
Replies: 3
Views: 44

Re: B3 internal wifi interface slot

Don't forget you need antennas as well
by Gordon
15 Jun 2017, 05:27
Forum: B2 & B3 Support
Topic: B3 internal wifi interface slot
Replies: 3
Views: 44

Re: B3 internal wifi interface slot

Half-size Mini PCI Express The stock card in a B3 is from Qualcomm and reports as 'Atheros AR928X'. Don't have an open unit at the moment, but I think this maps to a AR5B95 card. Of course there will be other brands (Realtek, Intel) and types that will also fit, but then there could be driver proble...
by Gordon
05 Jun 2017, 03:33
Forum: Development
Topic: B3: problem with 4.11 (and 4.12-rc3 mainline) kernels / sata_mv
Replies: 4
Views: 175

Re: B3: problem with 4.11 (and 4.12-rc3 mainline) kernels / sata_mv

Good job!

Wonder if this is restricted to the B3. Hardly seems possible that other systems would not be affected by this issue as well.
by Gordon
22 May 2017, 09:34
Forum: B2 & B3 Support
Topic: dhclient.conf Vendor Class Identifier (option 60)
Replies: 3
Views: 241

Re: dhclient.conf Vendor Class Identifier (option 60)

Yes. For home phone you would still need to use the ISP provided router. Could still be beneficial though to place it behind a VLAN splitter as this will put you in control of what signals can come in or go out of that router. As it happens my ISP provided me a router with a backdoor and I'm quite c...
by Gordon
08 May 2017, 02:20
Forum: B2 & B3 Support
Topic: dhclient.conf Vendor Class Identifier (option 60)
Replies: 3
Views: 241

Re: dhclient.conf Vendor Class Identifier (option 60)

That first link seems pretty cut-and-paste for your installation. One thing though: is it just internet you're getting on the fibre connection? Here in NL the bandwidth is shared with television and speech and it is the ISP provided router that splits these signals (separated by VLANs). By adding VL...
by Gordon
29 Apr 2017, 17:02
Forum: Development
Topic: Gentoo live-USB for Bubba|2 updated (Linux 4.9.16 LTS)
Replies: 15
Views: 740

Re: Gentoo live-USB for Bubba|2 updated (Linux 4.9.16 LTS)

I think that last command should be

Code: Select all

b2 ~ # revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc --getbinpkg
?
by Gordon
26 Apr 2017, 08:44
Forum: Development
Topic: Perl upgrade advise for Gentoo users!
Replies: 6
Views: 296

Re: Perl upgrade advise for Gentoo users!

Hi Sakaki, Well the thing is I masked it because my LMS binary did not have the necessary 5.24 components in it yet and portage told me to unmask it. So then I changed the keywords and portage told me to add perl 5.24 to accept_keywords. Apparently the way to block it is to mask all virtuals that wa...
by Gordon
25 Apr 2017, 17:12
Forum: Development
Topic: Bubbagen live-USB for B3 updated (Linux 4.4.39 LTS - Gentoo stable) + revision Apr 25
Replies: 1
Views: 222

Re: Bubbagen live-USB for B3 updated (Linux 4.4.39 LTS - Gentoo stable) + revision Apr 25

Probably the worst timing ever...

The very same day I released this version the Gentoo dev-team marked perl 5.24 stable. An upgrade that proved to be extremely troublesome. The updated link above points to a new image that contains both the upgrade to perl 5.24 *and* to gcc 5.4.0.

Enjoy,
Gordon
by Gordon
25 Apr 2017, 07:50
Forum: Development
Topic: Perl upgrade advise for Gentoo users!
Replies: 6
Views: 296

Re: WARNING for Gentoo users!

Hi Sakaki, Well, it started with ARM but they are gradually removing the '~' from all the other platforms as well. Today it was alpha that changed to stable. The main problem with this upgrade is that it is near impossible to stop it, while at the same time installed apps that have a dependency on p...
by Gordon
25 Apr 2017, 05:07
Forum: Development
Topic: Perl upgrade advise for Gentoo users!
Replies: 6
Views: 296

Re: WARNING for Gentoo users!

A follow-up on this issue. Perl 5.24 is being rolled out as stable, so no mistake though it is confusing that the devs are changing keywords in existing ebuilds. The problem with perl 5.24 is that the upgrade is very troublesome and it is also near impossible to mask it. The suggested method to upgr...
by Gordon
07 Apr 2017, 15:31
Forum: Development
Topic: Perl upgrade advise for Gentoo users!
Replies: 6
Views: 296

Perl upgrade advise for Gentoo users!

On April 6, 2017 there was a change in the portage tree that will cause your B3 to want to upgrade perl to (currently unstable) version 5.24. This appears to be a mistake that only affects ARM based systems (so Bubba|2 users will be safe). My advice to you all is to hold back on syncing until this i...
by Gordon
06 Apr 2017, 03:02
Forum: Development
Topic: Bubbagen live-USB for B3 updated (Linux 4.4.39 LTS - Gentoo stable) + revision Apr 25
Replies: 1
Views: 222

Bubbagen live-USB for B3 updated (Linux 4.4.39 LTS - Gentoo stable) + revision Apr 25

Update: see next post Hi, I've just released versions 1.9.1 (OpenRC) and 1.9.6 (Systemd) of the Bubbagen live-USB image for B3 on GitHub. The kernel has had a minor update to sublevel 39 which was selected as stable version by the Gentoo devs. Like the original Gentoo live-USB by Sakaki you can burn...
by Gordon
25 Mar 2017, 04:03
Forum: Development
Topic: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)
Replies: 25
Views: 2636

Re: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)

AFAIK there is nothing in Sakaki's original image that would require MySQL. She just added it because people requested it and doing the compile job yourself (without a crossdev environment) takes more or less forever. There are likely some circular dependencies, including dev-perl/DBD-mysql en proba...
by Gordon
24 Mar 2017, 17:42
Forum: Development
Topic: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)
Replies: 25
Views: 2636

Re: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)

Seems familiar. Of course in my system I eliminated mysql, so I don't get this particular issue any more. Nasty trick, but you can simply remove these two packages, DBD-mysql and Error. Then reattempt the updates. Whatever is not pulled in automatically during the updates can be fixed later by runni...
by Gordon
23 Mar 2017, 09:55
Forum: Development
Topic: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)
Replies: 25
Views: 2636

Re: Gentoo live-USB for Bubba|2 updated (rev 1 boards supported)

Ah yes. Perl is quite nasty when moving to a newer version. There are no vital components that require perl though, so it is quite okay to follow the suggested method of upgrading perl with --nodeps and then run perl-cleaner.